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NOTICE

Winvelope is not public domain or free software.  If you paid a shareware distributor for 
this program, you paid for the service of coping and distributing to you an evaluation disk
and not for the program itself.  You may evaluate Winvelope for a maximum of 30 days 
without charge, however if you find the program useful and continue to use it beyon the 
30 day evaluation period.  you must send a registration payment to the author.  Registered
users get the latest version of the software, notice of upgrades, and continued product 
support.

REGISTRATION INFORMATION

The single user registration fee for Winvelope is $20.00 U.S. (add $4.00 for shipping 
outside the U.S.).  A convenient printable online registration/order form is provided under
Winvelope's Help menu.  To order by mail, send a check or money order for the correct 
amount to:

J. E. McCullum
P.O. Box 1145

Jenkins, KY  41537

To order by phone using any major credit card, call the Public Software Library (PsL) at 
(800) 242-4775 and ask for Winvelope, product #10401.  This toll free number is for 
registering only!  Direct all calls concerning product support or information to the author 
at (606) 832-2493, 6:00-9:00 pm Eastern Time Zone.

WARRANTY DISCLAIMER

J. E. McCullum, the author of Winvelope, hereby disclaims all warranties relating to this 
software, whether expressed or implied, including without limitation any implied 
warranties of merchantability or fitness for a particular purpose.  The author will not be 
liable for any special, incidental, consequential, indirect or similar damages due to loss of
data or any other reason even if the author or an agent of the author has been advised of 
the possibility of such damages.  In no event shall the author's liability for any damages 
ever exceed the price paid for the license to use the software, regardless of the form of the
claim.  The person using the software bears all risk as to the quality and performance of 
the software.  If you do not agree with the terms of this disclaimer, you may return the 
software within ten (10) days of receipt for a refund of the purchase price. 
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1.0 Introduction
________________________________________________________________________

Winvelope is a utility program that simplifies the printing of envelopes from the 
Windows environment.  Winvelope accomplishes this task in just a few quick keystrokes 
and adds a host of convenient features in the process.  Now instead of having to re-type 
the address, the user can copy it from a Windows document via the Clipboard and paste it
directly to an envelope.  

Winvelope can be loaded and minimized to an icon when starting Windows so that it is 
always just a "mouse click" away.  A handy direct access to Windows Cardfile is also 
included for storing and retrieving frequently used addresses.

Features:

✉ Windows Copy n' Paste support for importing addresses from 
any document via the Clipboard.

✉ Automatically prints in landscape orientation for most printers that 
require it. 

✉ Print with mail merge from Windows Cardfile.

✉ Create and save any size envelope files.

✉ Maintain as many return address files as needed.

✉ Use a bitmap (.BMP) graphic file as the return address

✉ Fully adjustable print positions.

✉ Support for Windows installed printer fonts and attributes.

✉ Prints 5 digit and 9 digiit (ZIP+4) POSTNET bar codes.

✉ User friendly interface with generouse use of quick action icon 
buttons for most commands.

________________________________________________________________________
Winvelope v4.2 Page 6



2.0 System Requirements
________________________________________________________________________

Winvelope requires the following minimum hardware/software configuration:

✉ Computer with a 286 or greater CPU.

✉ Windows 3.x software installed in either "standard" or "386" mode.

✉ Windows CARDFILE.EXE installed in the Windows subdirectory.

✉ Printer supported by Windows and capable of feeding envelopes.

3.0 Installation
_______________________________________________________________________

To install Winvelope, insert the program disk in your disk drive a: and 
from Windows Program Manager, choose Run from the File menu.

Type a:setup and press Enter.

The setup program will prompt for the subdirectory name you want 
Winvelope installed to and then will proceed to copy the Winvelope 
files to your harddisk.  When finished copying, setup will install the 
Winvelope icon into a program group for Program Manager.

To have Winvelope load automatically with Windows, copy the 
Winvelope icon to your 'Start up' program group or modify the 
"load=" statement in the [Windows] section of the WIN.INI file to 
include WNVEL42.EXE.

[Windows]
load=[d:][path]WNVEL42.EXE

Refer to your Windows Manual for more detailed information on this 
procedure.
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4.0 Configuring Winvelope for your Printer
________________________________________________

To configure Winvelope for your printer choose Printing Defaults from 
the Options menu and make selections for the following settings:

4.1 Default Print Orientation

Select whether your printer prints envelopes in the portrait or 
landscape orientation.  After this selection is made and saved, 
Winvelope will automatically print the envelope in the correct 
orientation for most printers without having to access Printer Setup.  If 
landscape orientation is chosen, Winvelope will return the printer to 
portrait mode after the envelope is printed.  Some printers and/or 
printer drivers including Canon and Atech Publisher's Powerpak do not 
support this feature.  If you are using a non-HP compatible laser printer
and find that selection of landscape here does not change the 
orientation at print time, you will need to use the Winvelope Printer 
Setup button to change orientation before printing.

4.2 Bar Code Intensity

This control adjusts the print density (light/dark) of the POSTNET bar 
code.  Leave the setting on 'Normal' for 300 dpi laser printers, 
deskjets, inkjets, and most 24 pin dot matrix printers.  Change to 
'Darker' for 600 dpi laser printers such as the HP Laserjet 4.  Change 
to 'Lighter' for low resolution dot matrix printers.  When in doubt, set to
most closely match the bar code image found on mail that you have 
received.

4.3 Default Paper Bin Selection

This option, also found in the Printing Defaults dialog, is primarily for 
laser printers.  This setting will control which paper source will be 
accessed when the print job is sent to the printer.  This setting is 
particularly important to Hewlett Packard IIP, IIIP, and other similar 
type laser printers which will not feed an envelope from the manual 
feed tray when the lower paper cassette is installed without a direct 
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call from the software.  Owners of these printers will want to select BIN 
0 (UPPER TRAY), or BIN 2 (MANUAL FEED), if the lower paper cassette is
installed.  This will allow you to have the lower cassette as the primary 
paper source and Winvelope will print the envelope from the upper 
tray.  

Owners of other types of laser printers may use this setting to choose 
whether or not a manual feed prompt is desired when Winvelope prints
an envelope.  This may be desirable if the printer is located a distance 
from the user or if the printer is being shared and there is potential for 
someone else's printjob ending up on your envelope!  A little trial and 
error 
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may be necessary here to get the desired effect, as a particular BIN 
number may produce different effects on different brands and models 
of printers.  If you opt for manual feed, it is suggested that you select a
BIN number that prompts for MANUAL FEED LETTER not MANUAL 
FEED COM10.  

The following chart shows the paper bin number assignments for some 
popular laser printers:

PRINTER MODEL Bin 0 Bin 1 Bin 2 Bin 3

HP Laserjet 4* MP Tray

HP Laserjet II UpperTray ManualFeed COM10
N/A

HP Laserjet IID UpperTray LowerTray ManualFeed

HP Laserjet IIIP MP Tray LowerTray ManualFeed

Epson EPL6000 UpperTray LowerTray ManualFeed

Oki Laserline6 UpperTray ManualFeed N/A

If after installing Winvelope you find the envelope won't feed or the 
address prints on a page from the wrong paper source, try different BIN
settings until the desired effect is obtained.

If you have a high capacity envelope feeder (tray) and find that
none of the BIN settings causes it to feed, select the 'Use 
Windows Printer Setup Dialog Instead' option.  With this 
setting, you will click the Printer Setup button and set the 
paper source prior to each print job.

*We suggest trying BIN 1 for the HP LJ4, and setting the MP 
Tray for CASS (Cassette), and the Control Panel Printer 
selection set to 'Auto Select'.
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5.0 Creating, Saving, and Using Envelope Files
________________________________________________

Winvelope comes with (4) four standard envelope files already created.
These include Business (#10), Executive (#9), Monarch (#7-3/4), and 
Catalog (6x9 inch).  These envelope files have pre-set print margins for
'center feed' HP Series II, III type laser printers.  The print margins will 
need to be adjusted for 'side feed' HP IIP, IIIP type printers.  Print 
margins may be adjusted for any envelope file to suit the user.

5.1 Using Supplied Envelope Files

To use one of the four supplied envelope files, click on  the 
corresponding icon button along the left edge of the screen.  Selections
may also be made by choosing Open Envelope under the File menu.  
The Winvelope window caption at the top of the screen will display the 
currently active enveleope file as 'Winvelope -> FILENAME.ENV'.  As 
you make choices of return address printing, font selections, bar code 
printing, etc., these preferences will automatically be saved to the 
corresponding envelope file.

5.1 Creating New Envelope Files

To create a new envelope file, choose New Envelope under the File 
menu.  Next, enter values for the top and left margins for the Return 
Address, Addressee, Message, FIM code, and POSTNET bar code.  Save 
the envelope using a descriptive filename that can be easily 
recognized.  Envelope files use the filename extender '.ENV'.  Later, as 
you select return address files, choose fonts, enable bar code printing, 
etc., these preferences will be automatically saved to the 
corresponding envelope files.  Envelope files that you have created and
saved may be recalled by choosing Open Envelope under the File menu
or by clicking the [?] icon button at the bottom left of the screen.

6.0 Creating, Saving and Using Return Address Files
________________________________________________
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A return address may be printed if desired.  To create a return address 
file, choose Create New Return Address under the File menu.  Enter the
return address text as you wish it to appear on the envelope and save 
using a descriptive filename that can be recognized later.  You can 
create and save as many return address files as needed.  After one or 
more return address files have been stored, you can select, enable, or 
disable return address printing as desired by clicking the appropriate 
icon button.
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7.0 Using a Bitmap (.BMP) Logo for the Return Address
________________________________________________

This feature does not support Postscript printing.  HP Laserjet 4 users may have to 
switch to Raster mode to print logos.

To print a graphic logo as a return address, choose Select Graphic Logo
under the Options menu and select a .BMP file.  Click on the icon 
button representing an envelope with a logo and the selected graphic 
will print as the return address.  Print position is controlled by the 
margin settings for the return address.  The screen image of the 
graphic is not to scale and the actual print scale will depend on the 
pixel size of the bitmap file.  A printed graphic requires 300 pixels per 
printed inch.  If you wish to print a graphic 2" x 1", the BMP image 
should be 600 x 100 pixels.  Use a program such as Paintbrush and set 
the image attributes to pixel units and size as described above.  Use all
of the work area to create or edit your image.  If you wish to 
incorporate a return address with the logo, use the text tools of the 
paint program to create this text.  Save the image as a monochrome 
(saves disk space) .BMP file.

These instruction will produce acceptable images printed at 300 dpi.  
Higher printer resolutions will require creating larger images (ie, 600 
pixels per printed inch for 600 dpi)
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8.0 Addressing the Envelope
________________________________________________

8.1 Methods for Addressing the Envelope

With Winvelope, there are three methods for addressing an envelope:

1. Capture an address from your Windows document by 
copying it to the Windows Clipboard.  Activate Winvelope 
and use the PASTE ADDRESS button to paste the address 
on the envelope.

2. From Winvelope, activate the CARDFILE button which will 
launch Windows Cardfile and the file ADBOOK.CRD.  
You may store and retrieve frequently used addresses 
here as a permanent address book.  Copy a selected 
address to the Clipboard and PASTE as in method 1.  To 

use alternate Cardfile files as the address book, choose Set 
Default Cardfile Data File from the Options menu.  You may 
want to create several address book files for private 
and business addresses or Christmas card lists, etc.   Refer 
to the Windows manual for more information on the use of Cardfile.

3. From Winvelope, type an address directly onto the 
envelope addressee text box.

8.2 Printing with Mail Merge from Windows Cardfile

Mail merge operations may be performed from databases set up in 
Windows Cardfile.  Begin by selecting 'Print with mail merge...' under 
Winvelope's FILE menu.  Click the 'Select file' button and choose a valid
Windows Cardfile file for the merge operation.

To print ALL the addresses contained in the Cardfile file, click the 'Print' 
button WITHOUT checking the 'Verify each address for printing' 
checkbox.

To print only selected addresses from a Cardfile file, check the 'Verify 
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each address for printing' checkbox prior to printing.  This causes each 
address to display with a PRINT, SKIP, or CANCEL option dialog.  This 
option only works well with smaller Cardfile databases.  If the database
is large, it will become too cumbersome to 'skip' through each address 
to find some near the end.  

You may need to change the BIN setting in Winvelope's Printing 
Defaults to cause a MANUAL FEED prompt or remove the paper from 
the tray, else the printer may try to
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feed a sheet of paper before you can place the next envelope.  If  you 
are using a dedicated envelope tray and none of the BIN settings cause
the tray to feed, then check the 'Use Windows Printer Setup Dialog 
Instead' option in Winvelope's Printing Defaults and setup the paper 
source using the 'Printer Setup' button.

The address information in Cardfile must be formatted correctly in 
order for the mail merge feature to work properly.  There are two 
correct formats for storing the address information in Cardfile.  One is 
to begin the address on the first line of the card and then leave a blank
line between the address and any phone/fax numbers or other 
information.  The other is to have the phone number on the first line, 
the second line blank, begin the address on the third line, and then 
leave a blank line between the address and any additional information.
The second format option allows the Auto-dial feature in Cardfile
to work.  DO NOT use a Cardfile database that contains graphics!  The 
sample Cardfile database supplied with Winvelope v4.2 or later 
demonstrates the correct format options.  The sample Cardfile 
database supplied with Winvelope versions prior to v4.2 are NOT 
correct, as they contain a graphic logo!

8.3 Printing a Message Line 

If you wish, you may select a message such as VIA AIRMAIL, from the listbox shown in
the lower left corner of the Winvelope screen for printing along with the address.  You 
may also type a message directly into the listbox or modify the listbox to include your 
own custom message by choosing Edit Message Text List from the Options menu.  Scroll
to the bottom of the listbox edit dialog and enter as many message lines as desired.
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9.0 Font Selection
_______________________________________________

9.1 Choosing Fonts

Printer fonts installed in Windows are available for selection when 
printing envelopes.  Individual selections can be made for the return 
address, addressee, and message text by choosing Fonts under the 
Text menu or clicking the 'Fonts' button and accessing the font menu 
dialog box.  Every time you change a font or attribute setting, the new 
value is saved with the corresponding envelope file to the 
WNVEL412.INI file in the Windows subdirectory.  When you switch 
between different size envelopes, your last settings used for each will 
be retrieved from this file.  If Winvelope cannot find a matching 
Windows screen font for the printer font chosen, a substitution of the 
HELV screen font will be made for display purposes.  The printer 
however will print the correct font.

9.2 Changing Font Attributes

Bold and/or italic type and font sizes for the return address, addressee,
and message text  may be selected from the Font dialog box.  Fonts 
may be sized between 6 and 28 pt. Changes in font size will be 
portrayed in the font dialog sample text boxe and on the Winvelope 
screen, but fonts sized 18-28 pt. will display as 18 pt.  in order to 
conserve screen space.

9.3 Converting Addressee Text to All Caps

The Postal Service now recommends using all capital letters when 
addressing mail.  Winvelope allows you to convert a pasted-in address 
to all caps by making the selection in the Text menu.  
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10. Printing POSTNET Bar Codes
________________________________________________

POSTNET barcodes and the FIM-A code may be printed if desired by 
making the s
elections in the Options menu or clicking the appropriate icon button.  
Print position adjustment is made in the Print Margin routine under the 
File menu.  

The FIM code, (5 vertical lines) only prints with ZIP+4 (9 digit) zip 
codes.  The FIM-A code indicates to postal scanning equipment that the
piece of mail contains a ZIP+4 zipcode and should be sorted for 
Courtesy Reply Mail.  The FIM code should be approximately 2" from 
the right edge of the envelope and as close to the top edge as 
possible.  
 
The beginning of the POSTNET barcode can be no more than 4 inches 
from the right edge of the envelope and approximately 1/4 inch from 
the bottom edge.
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11.0 Adjusting Print Margins
________________________________________________

11.1 Adjusting Print Margins

Winvelope has a very flexible adjustment for address print positions.  
Adjustment down to a tenth of an inch can be made to the top and left 
print margins for all printable items.  These adjustments are made by 
accessing the Print Margins under the File menu.    You may find it 
beneficial to print to an 8-1/2" x 11" sheet of paper first and then 
measure approximately how far margins need to be adjusted to hit the 
envelope.  Margins are measured from the extent of the printer's print 
range rather than from the edge of the envelope.  The exception to this
is if the user selects a paper bin that prompts for a COM 10 envelope.  
The margins will then be measured from the edge of the envelope.

11.2 Table of Suggested Print Margin Settings

Suggested margin values for HP II/III style, (center feed), and HP IIP/IIIP style, 
(side feed), laser printers are shown below:

Center feed Return Addressee Message FIM Code Bar code
(HP II/III) Top Left Top Left Top Left Top Left Top Left
Business (#10)2.2 1.6 3.8 6.0 5.0 2.2 2.0 8.3 5.7 6.9
Executive (#9)2.4 2.4 3.8 6.5 4.8 3.0 2.2 8.3 5.4 6.9
Monarch (#7) 2.4 4.6 3.8 7.5 4.8 5.0 2.2 8.3 5.4 6.9
Catalog (6x9) 1.5 2.3 3.8 5.8 6.0 3.0 1.1 8.3 6.5 6.9

Side feed
(HP IIP/IIIP and HP4)
Business (#10)0.1 1.7 1.6 6.0 3.0 2.2 0.0 8.3 3.5 6.8

Executive (#9)0.1 2.4 1.6 6.0 2.8 3.0 0.0 8.3 3.2
6.8 Monarch (#7) 0.1 4.7 1.6 7.3 2.6 5.0 0.0 8.3
3.1 6.8 Catalog (6x9) 0.2 1.7 2.8 5.5 5.2 2.0 0.0
8.3 5.8 6.8

Important!
These values are valid only if you are using a paper bin selection that causes an 
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uninterrupted print or causes the laser printer to prompt for MANUAL FEED LETTER.  
When using a bin number that prompts for FEED COM10, most laser printers will expect
the margin to be measured from the edge of the envelope instead of the maximum print 
range.
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12.0 Getting Help
________________________________________________

12.1 Winvelope Onscreen Help System

By activating the HELP pull-down menu or pressing F1, you can access 
the Winvelope onscreen help file with topic search.  This help system 
includes most of the information contained in this document.  Choose 
Using Help under the Help menu to get detailed instructions on using 
theWindows Help System.

12.2 Product Support
 
Product support can be obtained for Winvelope by any of the following 
means:

✉ Telephone: (606) 832-2493  
Please restrict calls between the hours of 6:00 pm and 9:00 pm Eastern 

Time Zone.  The author regrets that he cannot return 
phone calls to non- registered users.

✉ Fax: (606) 832-2493

✉ BBS: (606) 832-4029 (upgrades to Winvelope may be 
downloaded)

✉ Mail: J. E. McCullum
P.O. Box 1145
Jenkins, KY 41537-1145

✉ Compuserve ID 71620,24

________________________________________________________________________
Winvelope v4.2 Page 22



13.0 Trouble Shooting
________________________________________________

Problem: Winvelope doesn't print in landscape mode.

Solutions: Make sure landscape is selected in Printing Defaults under 
Winvelope's Option menu.

You may have a printer and/or printer driver that does not 
support this feature.  The current variety of Canon 
and Publisher's Powerpak drivers are know not to support 
Auto-landscape.  If you have one of these, you will need 
to use the 'Printer Setup' button that will allow you to switch to 

landscape and/or change paper trays manually.  

HP Deskjet users will need to activate the Winvelope 
'Printer Setup' button in order to select ENVELOPE as the paper
size prior to printing.

Problem: Winvelope does not print the barcode when selected.

Solution: Winvelope searches the last line of the address for the 
zipcode.  The last line of the address should be CITY, 
ST  ZIP, or the zipcode should be on the last line by 
itself.

The FIM code (5 verticle lines) does not print with 5 digit 
zipcodes.

Problem: Winvelope gives error message and won't load.

Solution: Make sure the VBRUN200.DLL file supplied on the 
Winvelope program diskette is located in the \
WINDOWS\SYSTEM subdirectory.   

If all else fails, erase the WNVEL42.INI file in the Windows 
subdirectory and re-install Winvelope from the floppy 
diskette.
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14.0 Sources for Windows Shareware Programs
________________________________________________

14.1 Shareware Distributors (Call and request a catalog)

The Public Software Library (PsL).......(800) 242-4775

CWI...................................................(800) 777-5636

Software Excitement............................(503) 826-8083

The Software Labs...............................(800) 359-9998

14.2 Public BBS's

(Modem settings: 1200-9600 baud, N, 8, 1)

Winvelope Support BBS.......................(606) 832-4029Jenkins, KY

Atlanta Windows BBS..........................(404) 516-0048 Woodstock,
GA

The Windows BBS...............................(607) 722-0177
Binghamton, NY
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